hdu 3449 Consumer 有依赖的01背包

Description

@H_403_7@ FJ is going to do some shopping,and before that,he needs some Boxes to carry the different kinds of stuff he is going to buy. Each Box is assigned to carry some specific kinds of stuff (that is to say,if he is going to buy one of these stuff,he has to buy the Box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping,he intends to get the highest value with the money.

Input

@H_403_7@ The first line will contain two integers,n (the number of Boxes 1 <= n <= 50),w (the amount of money FJ has,1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith Box 1<=pi<=1000),mi (1<=mi<=10 the number goods ith Box can carry),and mi pairs of numbers,the price cj (1<=cj<=100),the value vj(1<=vj<=1000000)

Output

@H_403_7@ For each test case,output the maximum value FJ can get

Sample Input

@H_403_7@
       
       
3 800 300 2 30 50 25 80 600 1 50 130 400 3 40 70 30 40 35 60

Sample Output

210
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
int dp[100][100010];
int main()
{
    int n,money;
    int Box,m;
    int w,p;
    while(~scanf("%d %d",&n,&money))
    {
        memset(dp[0],sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            scanf("%d %d",&Box,&m);
            for(int j=0; j<Box; j++)//这里肯定买不到
                dp[i][j]=-1;
            for(int j=Box; j<=money; j++)//这里就是选择i时先用上从的取得的价值-盒子的花费
                dp[i][j]=dp[i-1][j-Box];
            for(int j=0; j<m; j++)    //这里就是用01背包进行更新本层取得的价值
            {
                scanf("%d %d",&w,&p);
                for(int k=money; k>=w; k--)
                    if(dp[i][k-w]!=-1)
                        dp[i][k]=max(dp[i][k],dp[i][k-w]+p);
            }
            for(int j=0; j<=money; j++)//这里更新是因为不是每次求的得就是最大的因为它是在减去篮子钱的基础上和本层的比较
                dp[i][j]=max(dp[i-1][j],dp[i][j]);
        }
        printf("%d\n",dp[n][money]);
    }
    return 0;
}

滚动数组优化,内存减少了接近40倍给跪了--->>> 点击打开链接
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
int dp[100010];
int tem[100010];
int main()
{
    int n,&money))
    {
        memset(dp,&m);
            memcpy(tem,dp,sizeof(dp));
            /*for(int j=Box; j<=money; j++)//这里就是选择i时先用上从的取得的价值-盒子的花费
                dp[i][j]=dp[i-1][j-Box];*/
            for(int j=0; j<m; j++)    //这里就是用01背包进行更新本层取得的价值
            {
                scanf("%d %d",&p);
                for(int k=money-Box; k>=w; k--)

                        tem[k]=max(tem[k],tem[k-w]+p);
            }
            for(int j=Box; j<=money; j++)//这里更新是因为不是每次求的得就是最大的因为它是在减去篮子钱的基础上和本层的比较
                dp[j]=max(dp[j],tem[j-Box]);
        }
        printf("%d\n",dp[money]);
    }
    return 0;
}

下面写了一个错误的,特比注意有依赖的背包要考虑很多情况
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f3f
int dp[100][100010];
int main()
{
    int n,&m);
            for(int j=0; j<Box; j++)//这里肯定买不到
                dp[i][j]=-INF;
            /*for(int j=Box; j<=money; j++)//这里就是选择i时先用上从的取得的价值-盒子的花费
                dp[i][j]=dp[i-1][j-Box];*/
            for(int j=0; j<m; j++)    //这里就是用01背包进行更新本层取得的价值
            {
                scanf("%d %d",&p);
                for(int k=money; k>=w; k--)
                        dp[i][k]=max(dp[i][k],dp[i-1][k-w-money]+p);
            }
            /*for(int j=0; j<=money; j++)//这里更新是因为不是每次求的得就是最大的因为它是在减去篮子钱的基础上和本层的比较
                dp[i][j]=max(dp[i-1][j],dp[i][j]);*/
        }
        printf("%d\n",dp[n][money]);
    }
    return 0;
}
//这种情况我本来想忽略最后的比较但是忘了一个很重要的问题那就是如果不比较那么开始的杀死后全部赋值为-INF那么这个地方就影院不会更新

相关文章

适配器模式将一个类的接口转换成客户期望的另一个接口,使得原本接口不兼容的类可以相互合作。
策略模式定义了一系列算法族,并封装在类中,它们之间可以互相替换,此模式让算法的变化独立于使用算法...
设计模式讲的是如何编写可扩展、可维护、可读的高质量代码,它是针对软件开发中经常遇到的一些设计问题...
模板方法模式在一个方法中定义一个算法的骨架,而将一些步骤延迟到子类中,使得子类可以在不改变算法结...
迭代器模式提供了一种方法,用于遍历集合对象中的元素,而又不暴露其内部的细节。
外观模式又叫门面模式,它提供了一个统一的(高层)接口,用来访问子系统中的一群接口,使得子系统更容...