ZOJ 3818 正则表达式

前端之家收集整理的这篇文章主要介绍了ZOJ 3818 正则表达式前端之家小编觉得挺不错的,现在分享给大家,也给大家做个参考。
Pretty Poem

Time Limit: 2 Seconds Memory Limit: 65536 KB

Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can even write poetic code. Some poems has a strict rhyme scheme like "ABABA" or "ABABCAB". For example,"niconiconi" is composed of a rhyme scheme "ABABA" with A = "ni" and B = "co".

More technically,we call a poem pretty if it can be decomposed into one of the following rhyme scheme: "ABABA" or "ABABCAB". The symbolA,B and C are different continuous non-empty substrings of the poem. By the way,punctuation characters should be ignored when considering the rhyme scheme.

You are given a line of poem,please determine whether it is pretty or not.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a line of poem S (1 <= length(S) <= 50). S will only contains alphabet characters or punctuation characters.

Output

For each test case,output "Yes" if the poem is pretty,or "No" if not.

Sample Input

3
niconiconi~
pettan,pettan,tsurupettan
wafuwafu

Sample Output

Yes
Yes
No



唉,逗逼一开始没想到用正则,C++各种WA。


import java.io.File;
import java.util.Scanner;
import java.util.regex.Pattern;
public class Main {
	
	Scanner in; 
	boolean debug = true;
	public void go()throws Exception
	{
		debug = false;
		File file = new File("C:\\Users\\Admin\\Desktop\\in.txt");
		if(!debug)
			in = new Scanner(System.in);
		else in = new Scanner(file);
		int t; t = in.nextInt();
		while(t-- > 0)
		{
			String str = in.next();
			boolean flag = false;
			str = str.replaceAll("\\W|_","");
			for(int i = 1; i <= str.length(); i++)
			{
				String a = str.substring(0,i);
				for(int j = i+1; j <= str.length(); j++)
				{
					String b = str.substring(i,j);
					if(a.equals(b)) continue;
					Pattern pat = Pattern.compile(a+b+a+b+a);
					Pattern pat2 = Pattern.compile(a+b+a+b+"\\w+"+a+b);
					Pattern pat3 = Pattern.compile(a+b+a+b+b+a+b);
					Pattern pat4 = Pattern.compile(a+b+a+b+a+a+b);
					boolean ok = pat3.matcher(str).matches() || pat4.matcher(str).matches();
					if(!ok && (pat.matcher(str).matches() || pat2.matcher(str).matches()))
					{
						flag = true;
					}
				}
			}
			if(flag)
			{
				System.out.println("Yes");
			}
			else
				System.out.println("No");
		}
	}
	public static void main(String[] args) throws Exception
	{
		Main ma = new Main();
		ma.go();
	}
}



原文链接:https://www.f2er.com/regex/361316.html

猜你在找的正则表达式相关文章